Email deliverability issue Friday 1st January 2021 01:54:00


We are experiencing a deliverability issue.

Update:

We now have enough volume to send to Microsoft addresses.

Update:

We have begun sending to Microsoft addresses, though the volume is limited.

The new mail servers we have built are warming up nicely, and we have continued to build more mail servers.

Update:

Though we’re still working to resolve sending emails to Microsoft addresses, you can start sending broadcasts.

We've also been building new mail servers for the past few days. They're currently in warming up status.

Update:

Unlike Gmail, Yahoo, and Apple email addresses… Microsoft email addresses like hotmail, outlook, live have super aggressive and strict filters.

We need more time to safely warm up our mail servers just for Microsoft email addresses, so that in the near future you continue to enjoy high email deliverability to these email addresses like you always had.

Hence we have temporarily disabled sending to hotmail, outlook, live for the time being. We'll update again when we have allowed Microsoft email addresses.

For Gmail, Yahoo, Apple, and other email addresses, we did not disable sending to them... but we still recommend that you do not broadcast till at least Jan 8. Stopping your broadcasts will help resolve the deliverability/blacklist issue faster, so that we can enjoy great deliverability again like before.

We will update again on this page with our progress.

Update:

  • We're still working with Spamhaus to get our sending IPs delisted from their blacklist database.

  • Our bounce handler has finished processing the backlog of data.

  • We've also begun warming up new mail servers, but the daily sending volume for these new servers are still very low (because they are very new). We still highly recommend that you halt all broadcasts till at least Friday Jan 8. Stopping your broadcasts will help resolve the deliverability/blacklist issue faster, so that we can enjoy great deliverability again like before.


What happened:

On Dec 13 and 14 of 2020 Gmail suffered a global outage. The outage on Dec 14 also caused them to give the wrong status message to email messages that tried to come in to Gmail inboxes.

In essence, Gmail told us that ALL email messages that tried to come in were bounced — when in fact the majority weren't.

This meant there were a lot of false bounces — but we don’t know which ones really did bounce and which ones did not. Hence we decided not to unsubscribe these email addresses, and instead put them back into your account (because we don’t want you to lose subscribers unnecessarily).

This also means our bounce handler has to process a lot of data (in addition to Gmail bounces, it also has to process real bounces from other inbox providers like Yahoo, Hotmail, etc) — which resulted in a huge backlog of data waiting to be processed by our bounce handler.

Before our bounce handler can mark these email addresses as bounced... users keep sending more email messages to these addresses. Because of this, Spamhaus - a spam monitoring organization - thought that we do not practice good list hygiene, when in fact we do. Hence they blacklisted our sending IPs.

.

How we are going to resolve it:

We are currently working with Spamhaus to delist our sending IPs from their blacklist database.

We are going to increase the amount of engineering capability dedicated to email deliverability, including more streamlined and efficient processes, and better infrastructure.

.

We suggest you to halt all broadcasts at least for the next 7 days (till Friday Jan 8)

Stopping your broadcasts will help resolve this issue faster.

Working with Spamhaus and also processing the remaining backlog of bounces takes time, and we highly recommend that you:


Halt all broadcasts at least for the next 7 days (till Friday Jan 8). Stopping your broadcasts will help resolve this issue faster.


If you insist on sending broascasts during this period, the deliverability and open rate won’t be good, and there will be many bounces.

We appreciate that you entrust us to help you communicate with your subscribers, and it’s unfortunate that problems do occur in business. Through this incident, we’ll become stronger and better in making sure similar incidents don’t happen again.

We understand this is not ideal, and we try to be as transparent as possible. We apologize for the inconvenience caused.

We’ll keep you updated with the progress here.